Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 7 of 7

Thread: Program with TTL signals closing prematurely (case 2833)

  1. #1

    Program with TTL signals closing prematurely (case 2833)

    [thread title edited by moderator]

    Hi there,
    I have a task that I programmed in the 2006 version, and it worked perfectly on that computer. Now when I put the files onto the lab computers, which have the 2010 version installed, the program basically closes down after the first two trials, as if the participant has completed the entire task. Any help in resolving this would be greatly appreciated!

    Attached Files Attached Files
    Last edited by jarvis24; 10-24-2012 at 02:18 PM.

  2. #2
    Join Date
    Aug 2012
    Sure--two questions. Is this 2010.2 or 2010.3. And is this Windows 7? If you were running 2006 on the first computer, I'll assume that one is an XP machine? If these are ALSO XP machines then, it maybe be a 2010.2 vs 2010.3 version issue. If it's Windows 7, it's likely due to Windows 7 needing v2012 to send and receive TTL signals (which I notice you are using in your input file). Sorry if that sounded probably sounded waaay confusing--please feel free to ask for elaboration!

  3. #3
    Join Date
    Aug 2012
    Another thing you could do is see if it's related to the TTLs. A kinda easy way to do that is make a copy of the input file and change all the instances of "ttl:111" to "~ttl:111", "888" to "0,0,1" and "5" to "500". Just to make it a simple text stimulus--does that make sense?

    If -that- stops the crashing, my guess would be that it's a TTL issue (genius huh?). If so, we could troubleshoot from there, probably by trying v2012. If it STILL crashes, then we'd go in a very different troubleshooting direction (e.g., scrutinizing the syntax). But as I mentioned before, if these new ones are Windows 7 machines, chances are they simply need v2012.

    Hope that helps!

  4. #4
    Thanks for responding. I've actually installed the latest 2010 version and it seems to have solved the problem. However, I now have a different issue which is that MediaLab won't call up the DirectRT file. I browsed through the forums and found this:

    "From the Windows Start menu, type "regedit" and navigate to the following registry keys:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\App Paths\directrt.exe


    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\App Paths\executeDRT.exe

    In both cases, there needs to be a string variable called "Path" and the value needs to be "C:\DirectRT\" or wherever the folder is located that holds the directrt.exe and executedrt.exe files.

    Note the key needs to be named "Path". If there is no such key you may need to create it. Just right click and select "New > String Value". Name it "Path" and assign the "C:\DirectRT\" value to it."
    However, when I go into the app paths registry, the directrt.exe is not there, only the executeDRT.exe is there. I suspect this is causing the problem, but I'm not sure how I would go about fixing it.

    Thanks again...

  5. #5
    Join Date
    Aug 2012
    Yes, that is almost certainly the issue. Not sure why the directrt.exe key would be missing though--maybe erased by a registry cleaner since it had an invalid path. (?) Can you create a new "directrt.exe" key that is in other respects identical to the "executedrt.exe" key? i.e., including the correct path as described above? Or maybe re-install 2010.3 (unless, of course, you JUST installed it) and then correct it as described above (I expect you would see it after a re-install if a registry cleaner deleted it).

    Hope that helps!

    PS., And just curious--was it 2010.2 that had been on these machine prior to the new 2010.3 install? And XP or Windows 7? Would just like to keep track in case someone else experiences a similar issue. Thanks for the update!

  6. #6
    Yes, it was 2010.2 and it was Windows 7.

    In regards to the issue - I tried to create a new key but I got a message that I don't have the requisite permissions to do this.... any advice?
    And yes, I just installed 2010.3 on all the computers, so I'm not sure if a reinstall would do it...

    I have the same issue happening on all 5 lab computers...

    thanks again!
    Last edited by rimma; 10-29-2012 at 10:17 AM.

  7. #7
    Join Date
    Feb 2013

    Please let us know if you need any more help resolving this issue.
    Jason Reed
    Empirisoft Software Support Specialist

Similar Threads

  1. TTL signals via Bluetooth? (case 407)
    By marga in forum DirectRT Older Versions: General Questions
    Replies: 1
    Last Post: 05-05-2015, 02:10 PM
  2. TTL signals via Bluetooth (case 144)
    By marga in forum DirectRT Older Versions: General Questions
    Replies: 0
    Last Post: 07-12-2012, 04:41 PM
  3. Sending TTL Signals (case 472)
    By jbeylev in forum DirectRT Older Versions: General Questions
    Replies: 2
    Last Post: 04-01-2012, 12:05 PM
  4. TTL SIgnals - Pins?
    By jbeylev in forum DirectRT Older Versions: General Questions
    Replies: 2
    Last Post: 02-28-2012, 07:21 AM
  5. Closing browser after playing custom file leads to black screen in MediaLab
    By clawton in forum MediaLab Older Versions: General Questions
    Replies: 0
    Last Post: 10-04-2011, 08:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts