Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 2 of 2

Thread: Scale response questionnaire data written as string (case 2799)

  1. #1

    Scale response questionnaire data written as string (case 2799)

    Hi, thanks for looking at my post.

    First of all, here's the context of my problems. I built an experiment with multiple questionnaires. I have 8 conditions and 5 questionnaires. All questionnaires are exactly the same across all 8 conditions, and are all scale response. The problematic questionnaire, which I will refer to as Questionnaire PI, can write data into Excel and SPSS perfectly when it's run alone. However, when it is run together with the other questionnaires as a complete experiment, I would get an error message at the end of the experiment that says the data for the variables from questionnaire PI are in string format but will be written as numeric value in SPSS. Now the scale response for this questionnaire has 11 anchor points with the text label for the first point and the last point being relatively long (i.e., 6 words including a comma). I tried cutting down the length of the text label for the anchor points, the error message is gone, but the data written for this whole questionnaire become 99.

    Has anyone had problem like this before? If you did, how did you solve it? Any advice, suggestion or direction would be highly appreciated. Thanks!!!

  2. #2
    Join Date
    Feb 2013
    It seems like this could be an issue with the WriteText option. Check that this option is turned off in the PI questionnaire, (and in the other questionnaires, as it might be being carried over from a previous one in the experiment).

    It's also possible that the commas in the text anchors are interfering with the parsing of the data file. This possibility seems unlikely given the pattern of problems you describe, but it would be worth checking if deleting the commas in the text anchors stops the error.

    If these don't work, one other thing to consider is whether the issue is being caused by a prior questionnaire in the experiment. To test this, try making a version of the experiment with the PI questionnaire preceding the others (or, if this is already an experimental condition, just run that condition). If that runs without the error message, it suggests the problem is with the settings in a prior questionnaire being carried over (which would be consistent with you not experiencing the problem when the PI questionnaire is run alone). If you still get the error, it suggests it is a problem with the PI questionnaire itself.
    Last edited by jason_reed; 05-23-2014 at 02:51 PM.

Similar Threads

  1. String data will be saved as numeric in SPSS (case 10109)
    By jarvis24 in forum MediaLab Older Versions: Troubleshooting
    Replies: 3
    Last Post: 09-16-2013, 11:31 AM
  2. Show timer throughout questionnaire (case 7629)
    By scmlab in forum MediaLab v2018: How Do I...
    Replies: 2
    Last Post: 05-01-2013, 10:35 AM
  3. Replies: 1
    Last Post: 03-16-2013, 08:12 PM
  4. How to write a questionnaire in Hindi? (case 166)
    By eve26 in forum MediaLab Older Versions: How Do I...
    Replies: 4
    Last Post: 12-04-2012, 03:05 PM
  5. data not written to spss file; where else can it be?
    By obraztsova in forum MediaLab Older Versions: General Questions
    Replies: 4
    Last Post: 10-30-2007, 01:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts