Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 2 of 2

Thread: Possible reason for missing data

  1. #1
    Join Date
    Nov 2005
    Posts
    3,323

    Possible reason for missing data

    [edited from support email]

    We were finding that we were missing all of the data for some cases and finally figured out the problem. The RA that ran the sessions where there were missing data was terminating the medialab session prematurely, thus causing a loss of data. We have a screen at the end of the final task that says 'congratulations, you have finished the task' (with celebratory balloons on it). After that screen appears, the RA can either use ctrl+ right arrow to advance to the last screen or simply wait until the program advances itself to that final dialogue box.

    It turns out that this RA would sometimes pull up the Windows task bar at the balloons/congratulations screen and exit out of program from there at that time. We think it didn't happen for all of her subjects because she'd run multiple subjects in one session and simply couldn't close all of those congrats windows prematurely before they automatically advanced to the final screen where the data is recorded.

    Now we will always include something in our protocols to alert RAs to this issue (I am surprised it hasn't occurred before in the 2 years we've used MediaLab). I really appreciate your helping me in trying to solve this problem. I am also relieved to discover it was human error rather than a problem with our program.

    Thanks again for everything. Happy Holidays.

  2. #2
    Join Date
    Nov 2005
    Posts
    3,323
    Thanks for the update--I've heard of a similar result when someone has hit ctrl+alt+delete to end a session which would have the same result. FYI, an easy way to end the sessions in a secure way is to use the password option in the Preferences menu (Preferences > Edit Preferences > Password to Exit Experiments). That way you don't need to use a timer and you can exit out at your convenience.

    [edited from a related support email, Oct 16, 2008]

    Thanks for getting back to me. Yes, we are saving the data locally to the same folder, and all of the sessions are being run on the same computer. I think that I may have figured out the problem - it appears that if you exit out of the program incorrectly (i.e., using the Windows button on the keyboard and then right clicking on the tab at the bottom of the screen to exit) the individual text response files save, but not the SPSS data. Does that make sense? I originally didn't think that was the problem since some of the data was saving, but I was able to recreate the missing data when I ran a test and closed out that way. I assume there is no way to recover the data that we lost, but please let me know if there is a way.
    Yes, I think that would certainly explain it. MediaLab needs to completely finish the session before the data files are modified (with the exception of some external data files such as those for essays which are saved immediately after the item occurs). Unfortunately, I don’t expect there is a way to recover those data because closing MediaLab via the taskbar doesn’t allow the program to execute any additional lines of code (e.g., those required to save the data).
    Last edited by jarvis24; 10-16-2008 at 09:58 AM.

Similar Threads

  1. Missing LOC value
    By jarvis24 in forum DirectRT Older Versions: Troubleshooting
    Replies: 17
    Last Post: 06-20-2018, 05:09 PM
  2. missing values
    By Jessica in forum MediaLab Older Versions: How Do I...
    Replies: 3
    Last Post: 02-29-2008, 09:25 AM
  3. SPSS .sav data is missing new variables?
    By Sonia in forum MediaLab Older Versions: General Questions
    Replies: 9
    Last Post: 08-22-2007, 12:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •