Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 5 of 5

Thread: Microphone and voice RT problems

  1. #1
    Join Date
    Nov 2010

    Microphone and voice RT problems

    I've run into the following problems in trying to set up an experiment requiring vocal responses and am at a loss about what to do. I have DirectRT 2008.1.0.13 and Dell optiplex 760 computers.

    The first problem is that the microphone input is not always detected, even when there's a microphone plugged in. Unplugging and re-plugging usually helps, but it seems problematic to regularly have to do that. It's more of an issue with the jack at the rear of the computer, but happens with the front jack as well. Sometimes after unplugging and re-plugging, it will say either the front or rear microphone is now the selected recording device, but that's still not always recognized by DirectRT and we have to unplug and re-plug again.

    The even bigger problem though is that vocal input and RTs are not being recorded properly. When testing the voice response in DirectRT it sometimes seems to work fine for a bit, in terms of the monitoring and RT test functions, but other times it seems to pick up some weird electrical noise in the system even when there's no voice input. The blue line goes haywire and flashes like crazy and we get really short RTs of 0ms, 6ms, 17ms etc... even when there's no voice because they seem to be triggered by the weird electrical noise and those sound files just sound like static.

    This seems to happen randomly. Will be fine for a few seconds or minutes, then problematic for a bit, then fine again, and go back and forth like that. Moving the sensitivity to the end helps a bit but the problem persists and then it's harder to get actual voice RTs. It seems to be a DirectRT software problem because when we test the microphones using the "sound and audio devices" hardware test in the control panel they seem work fine. We encounter the same problem on other computers of the same type, and with 2 different microphones. My IT dept has also tested another computer and sound card and the problem persists. They are convinced it's a software issue too.

    Would really appreciate some help since I'm completely at a loss about what to do and really need to be able to run this and other vocal response exps with accurately recorded RTs.

  2. #2
    Join Date
    Nov 2005
    I would suggest trying the latest version of DirectRT on on of the systems upon which these issues are occurring. Download the latest version from the main download page (www.empirisoft.com/download.aspx) and select the option to install v2008 when prompted. You can obtain a replacement code for it through our sales@ email address. That may resolve it because much of the code involving sound was re-written for the latest release. Let me know how it goes!

    ps., I meant to first say that it sounds like a hardware issue of some kind more than a software issue, but just in case, I would try this (i.e., the above suggestion). The newest version is helping to remedy a handful of multi-media related issues.

  3. #3
    Join Date
    Nov 2010
    Thanks. That seems to have solved the problem. There's still some indication of electrical noise in that the green bar in the voice response utility flickers back and forth a bit even when there's absolutely no vocal input, but the sensitivity can be moved far enough along that only actual voice responses will trigger an RT.

    However, the RTs recorded are a lot longer than they should be (well over 1000 ms) and I think my input file is problematic. I want a fixation cross to be up there for 750 ms before a word stim appears for 160ms and the fixation cross to stay for at least 250 ms after the word stim disappears, with a vocal RT to the subject's response to the word stimulus, making sure that to record the whole sound file of their word response. I had a hard time figuring out how to do this, but the input file I came up with is:

    [edited a bit here for formatting by moderator]
    On each trial, three combinations of stim, loc and time as follows:
     ~+   0,0,1   750  
    ~CLOUDY <3>   1025,575,0   160   
    ~+ <1>   0,0,1   RT:aud,rec,-1500
    Would appreciate help on how to correct the input file accordingly so that the RTs will be accurate. Thanks.
    Last edited by jarvis24; 11-23-2010 at 03:38 PM.

  4. #4
    Join Date
    Nov 2005
    First off, if you use the RT test utility, do the RTs seem appropriate? Second, do you have a sample voice file that was recorded and the RT specified for that trial from the log data?

  5. #5
    Join Date
    Mar 2021
    I tried using my microphone, yet found it wasn't working despite using it only a few weeks prior. I went through a few settings and found out that my microphone is apparently (which is set to default by the way) not plugged, however it definitely is as I can see it is. I use a splitter that goes through 2 jacks for mic and headphones respectively and this is where I'm confused. Although it says it's in, if I have it loosely placed in the jack it detects the device, yet the mic still wont work (there's just static). When it is fully in, it is not detected and when taken out it isn't detected. I use Realtek HD Audio with all drivers updated. I've spent a few hours trying to fix this with a variety of methods: restarting the PC, activating the windows troubleshoot which told me the device wasn't plugged in, messing with the jack for a while, making sure all drivers were up to date, recording my voice on serveral platforms, making sure it wasn't disabled/muted, browsing google and youtube for any answers and a few other things. Nothing has worked so far. The better solution is buying cheap mic from this review.
    Last edited by Frederica; 03-31-2021 at 12:06 PM.

Similar Threads

  1. Microphone input connection error
    By hoardm in forum Hardware: Troubleshooting
    Replies: 1
    Last Post: 08-16-2010, 11:06 AM
  2. Voice RT
    By jae in forum MediaLab Older Versions: General Questions
    Replies: 1
    Last Post: 06-12-2009, 12:29 PM
  3. Can you recommend a microphone?
    By JEC in forum Hardware Questions
    Replies: 6
    Last Post: 03-31-2009, 08:31 PM
  4. How accurate is the RT when a microphone is used?
    By lisabarella in forum DirectRT Older Versions: General Questions
    Replies: 1
    Last Post: 10-26-2007, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts