Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 9 of 9

Thread: Authorization code does not work--and the number changes

  1. #1
    Join Date
    Nov 2005

    Exclamation Authorization code does not work--and the number changes

    [edited from support email]

    I write to you because I had a problem with the code of MediaLab installed one of our computers. MediaLab generates a different ATX code each time we try to open it. When we enter the license number we received it did not work and the software generated the second ATX code and so on. Is there a problem with the installation procedure or anything we're doing improperly?

  2. #2
    Join Date
    Nov 2005
    Your probably do not have read/write permissions for the MediaLab/DirectRT folders. This will cause the license check to fail. if this is the case then the folder permissions need to be set by someone with administrator-level access. The following steps should make everything work (e.g., while logged on as a regular user):
    1. Log on as an administrator
    2. Right click on the MediaLab/DirectRT folder and select Properties and then Security and ensure that regular users have Read/Write permission.
    3. Only if you do not see a Security tab, then:
    4. Open Folder Options in the Windows Control Panel. On the View tab, make sure Use simple file sharing is not checked. It should be one of the last options.
    5. Go back to step #2.
    That should do it. Let us know if you have any trouble with it.



    Newell Edit (DirectRT 2008 [Vista-compatible version] / 2010):
    To assign the proper permissions to a 2008/2010 copy of DirectRT, the following steps will need to be taken:
    1. Log on as an administrator.
    2. Open up Windows Explorer. This can be accomplished through the start menu or by pressing the 'Windows key + E' .
    3. Navigate to the folder Program Files\Empirisoft\DirectRT 2010 .
    4. Right-click on the folder titled Components and navigate to the Properties menu item.
    5. Navigate to the Security tab. If you do not see the Security tab, Blair's comments above note how to enable the tab.
    6. From the security tab, select the button 'Edit...'
    7. In the top control that lists each user group, select Users. In the bottom control select the checkbox for 'Full control' under the Allow column. Upon seeing that each checkbox is now filled for this column, select Apply and then press OK .
    8. Press OK on the previous dialog box. You're now finished setting up the proper user permissions.
    Last edited by Trevor Newell; 11-19-2009 at 05:24 PM.

  3. #3
    Join Date
    Nov 2005
    Also.. if you install an update file such as medialab.exe, be sure you read the readme.txt file that comes with it. The update file must go into the existing MediaLab folder, overwriting the older version of the same file. If you simply try to run the update file from some other location, you will be prompted for a new code.

  4. #4
    Join Date
    Nov 2005

  5. #5
    Join Date
    Nov 2005
    Three other tricks:

    For Windows XP, 2000, etc:

    Click on the DirectRT / MediaLab folder (the entire folder) and instead of read / write, select 'full control'.

    Also, if the code still doesn't remain stable after making these changes, delete the file 'license.dll' from the MediaLab / DirectRT folder. Restart the program, then see if the new number generated remains the same.

    I have known of one user who found that made a difference.

    For Windows Vista and the Beta version of DirectRT:

    When logged in as an admin, try deleting the file license2008.dll and then start the program again. The file will be re-generated. See if that gives you a stable code when you open and close the window a few times.

    Once the code is stable, we can send you an activation code which works.
    Last edited by JEC; 09-29-2008 at 02:21 PM.

  6. #6
    Join Date
    Nov 2005
    One final idea which especially relates to site licenses and IP-based authentication:

    On rare occasions, people have experienced a message box displaying

    "Automation error ClassFactory cannot supply requesed class"

    A solution to this is typing the following from within the windows 'Run' menu:

    regsvr32 c:\directrt\license2008ip.dll

  7. #7
    Join Date
    Nov 2005
    One user also reported that re-installing solved the problem when the 'regsvr' command mentioned above didn't work.

  8. #8
    Join Date
    Nov 2005
    Important Note:

    Blair's post at the top of this thread refers to changing the read/write permissions of the actual folder that DirectRT / MediaLab live in. This is typically C:\MediaLab or C:\DirectRT for the 2008 versions.

    If you just right-click on the MediaLab / DirectRT icon on your desktop, then it will change the permissions only on the shortcut--not on the main folders and so changes won't have the desired impact.

    So the important note again here: Be sure to use the file explorer / My Computer shortcut and apply these changes to the program folder.
    Last edited by jarvis24; 03-24-2009 at 03:30 PM.

  9. #9
    Join Date
    Mar 2009
    [edited from related support email]

    It worked! The group 'USERS' did not have write permission regardless of whether the user had admin privileges. I added the write permission and relaunched DirectRT and it gave me the original code. I entered the response code you sent and it worked! Thanks and have a good weekend.

Similar Threads

  1. styles won't work
    By Rene Kopietz in forum MediaLab Older Versions: Troubleshooting
    Replies: 9
    Last Post: 10-10-2008, 04:28 PM
  2. New code prompt changes each time we open and close the window
    By jarvis24 in forum Pre-Sales and Licensing FAQ
    Replies: 2
    Last Post: 11-09-2007, 01:30 PM
  3. Voice response times ending in same number
    By jarvis24 in forum DirectRT Older Versions: Troubleshooting
    Replies: 8
    Last Post: 01-31-2007, 03:15 PM
  4. Request for new license code?
    By jarvis24 in forum DirectRT Older Versions: Troubleshooting
    Replies: 1
    Last Post: 09-27-2006, 11:22 AM
  5. Port number for a Cedrus device?
    By jarvis24 in forum Hardware: How Do I...
    Replies: 13
    Last Post: 07-11-2006, 04:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts