Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 6 of 6

Thread: Having problems with TTL on Vista

  1. #1
    Join Date
    Sep 2009

    Having problems with TTL on Vista

    Hello everyone, I am a graduate student from Taiwan. My english is not very well (or poor, I think). But I'll try to express my questions clear
    I've been working on MediaLab to let it synchronize with Biopac MP150 (with UIM100C), but have confronted great troubles.........

    Computers bought these years seem not having parellel port at all, so I bought one PCI I/O card (with parallel port) and successfully installed it 7 hours ago. By the way, the OS of my computer is Vista 32-bit.

    However, when I downloaded the patched IOTest from this forum and started to test it, in the Port Address field it always showed "LPT1: Error", "LPT2: Error", "LPT3: Error". I've tried to type the decimal values of the port (the hex value is DC00-DC07; D480-D487) and set the byte value and time to 255/50, but there were changes in Monitor field, the value remains 0.

    At first, I thought this was the problem of the I/O card, so I went out and bought another one. However, both of them are made with Moschip's chip, so I think they are the same. And result is the same as well (sigh....)

    Then, I thought this might be the problem of Vista, so I used the IOTest program on the other computer with XP. The result was a bit of different, this time, Port Address field showed "LPT1 Absent" rather than "LPT1: Error". This was rather convincing, because this computer surely has no parallel ports.

    Can anyone gives me some suggestions and hints? Without letting MediaLab synchronize with Biopac, I can not graduate .....

    Thanks for your watching, hope my extremely poor english didn't make the questions more difficult to understand.

    Best regards

  2. #2
    Join Date
    Mar 2009
    Just an update: Currently awaiting a response back through email.

  3. #3
    Join Date
    Sep 2009
    Thanks for giving me several helpful tips. However, I still can't get the attached I/O card work, no matter how many cards I change (I've bought 3 kinds of cards already), medialab and IOTest just can't get the card's address (even I enter the decimal values on my own).

    Therefore, I decided to set up an whole new computer. It's hard to find a LGA775 socket motherboard with a parallel port, but still I found one. Thank God, medialab and IOTest work perfectly on this computer, it seems like that medialab and IOTest prefer the default port address (888) than the attached I/O card. Maybe it's the operating system's cause (this time I install XP rather than crappy Vista), but I think it's not.

    Everything works smoothly since I set up a new computer, I even built one black box to transfer the signals from computer to biopac's I/O channels, this is another story I think.

    Thanks for the tips and helps, though the original problems are not really solved

    As always, please forgive my poor english :-P

  4. #4
    Join Date
    Nov 2005

    It turns out that DirectRT has a hard time with hardware addresses which are higher than 32,000.

    Hex DC00 ---> Decimal 56,320.

    We're working on a fix for this. In the interim, we'd recommend using a computer with a built-in parallel port for optimum reliability.

  5. #5
    Join Date
    Nov 2005
    Note that this should no longer be an issue as of v2010 due out this Spring (2010).

  6. #6
    Join Date
    Nov 2010
    The same problems mannylee reports we face with Windows7. I hope spring 2010 is soon over ;-)

Similar Threads

  1. TTL unsolved problems
    By mugur65 in forum MediaLab Older Versions: Troubleshooting
    Replies: 2
    Last Post: 06-22-2023, 04:27 AM
  2. Vista Compatibility?
    By jarvis24 in forum Pre-Sales and Licensing FAQ
    Replies: 14
    Last Post: 12-19-2009, 05:44 AM
  3. TTL-Problems with PCI-parallel port card
    By Thomas in forum Hardware: Troubleshooting
    Replies: 4
    Last Post: 05-10-2009, 02:25 PM
  4. TTL problems: I/O Test
    By Roelie in forum Hardware: Troubleshooting
    Replies: 6
    Last Post: 11-12-2008, 01:31 PM
  5. Problems with TTL
    By mugur65 in forum MediaLab Older Versions: Troubleshooting
    Replies: 2
    Last Post: 04-27-2007, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts