Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 5 of 5

Thread: TTL-Problems with PCI-parallel port card

  1. #1

    TTL-Problems with PCI-parallel port card

    I´m not able to send TTL-triggers to my EEG via my pci-parallel-port card.

    I use a MosChip PCI Parallel Port card (I/O area of EC00-EC07 (3072-3079) or E880-E887 (2176-2183)) with a V-Amp EEG-device (BrainProducts). If I connect the V-Amp to an "old" machine with an onboard parallel port (the 0378), everything´s fine and I can trigger the EEG by TTL. The LPT is also recognized by DRT-I/O-Test.

    If I try to trigger the EEG by using an up-to-date acer dualcore with the PCI-card aforementioned I/O-Test doesn´t recognize any LPT but I can sent a trigger to the port and I/O-Test monitor tells e.g. port3072=255. Changing bitvalue doesn´t change monitored bitvalue (always 255). I tried to use the decimalcodes of the I/O-area of the card (e.g. loc=3072 in the csv-file), doesn´t work.

    Card works properly, driver is installed and I can print with it. Additionally, V-Amp TTL-monitor shows changes in high-low of Bit 0-8 when I start the DRT-machine (with which I try to trigger the EEG-device).

    Any suggestions?


    P.S. Before I can send any TTL to the EEG by DRT, I first have to send machine to standby to set Bit 1-8 to low, both old machine as well as up-to-date acer. Is this the normal case!?

  2. #2
    OK, maybe I started a thread for the very same problem which was discussed in another thread. And, maybe, it was too cryptic that to get an answer.
    We now fixed it in that way that we searched for a mainboard which has an inbuild parallel port (we found an affordable ASUS-board, and nowadays it's really hard to find such a board, who needs a parallel port any more!?).


  3. #3
    Join Date
    Mar 2009
    Hm. It's peculiar that the motherboard worked when it had a parallel port built-in, but the PCI-parallel port card didn't work.

    I wonder if it's the card itself that was malfunctioning?
    Thanks for the update on the situation.

  4. #4
    Join Date
    Nov 2005
    FYI, running a forum search on "ttl parallel" will turn up a healthy portion of discussion on this. I can mention here though that one unresolved issue remains that port addresses greater than 32768 (decimal, or 8000 hex) may not work. On-board parallel port addresses (e.g., as opposed to OS-assigned add-on card addresses) tend to stay much lower than these max values and so that is usually a fix if this is the issue. But then again, if you had an on-board parallel port (i.e., directly built into your system/mother board) you probably wouldn't be reading this. Sigh. In any case, for v2010, we should have it worked out such that all port addresses work fine--to infinity and beyond.

  5. #5
    I connected an old HP Laserjet and printed with it. So I concluded that the card works.

    Ah, ok. The decimalcodes of my card are about 60000, so it seems that it could not work ;-).
    And that was exactly my question. We wanted to build up new labmachines for the EEG anyway, but I was unsure if I just made a mistake while testing the stuff with existing machines. So no worries, we didn't exchange a mainboard in an existing machine to get the stuff run ;-)
    But I must confess that I, apparently, have calculated wrong decimal-values for the hex-values of the I/O-area of my card (SHAME on me).

    Anyway, thanks to both of you for your responses,

Similar Threads

  1. TTL unsolved problems
    By mugur65 in forum MediaLab Older Versions: Troubleshooting
    Replies: 2
    Last Post: 06-22-2023, 04:27 AM
  2. TTL problems: I/O Test
    By Roelie in forum Hardware: Troubleshooting
    Replies: 6
    Last Post: 11-12-2008, 01:31 PM
  3. Parallel port address can not be read
    By bollsp in forum Hardware Questions
    Replies: 7
    Last Post: 11-11-2008, 10:13 AM
  4. Parallel Port and Vista
    By bollsp in forum Hardware Questions
    Replies: 0
    Last Post: 10-30-2008, 02:27 PM
  5. Problems with TTL
    By mugur65 in forum MediaLab Older Versions: Troubleshooting
    Replies: 2
    Last Post: 04-27-2007, 01:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts