Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 8 of 8

Thread: Parallel port address can not be read

  1. #1

    Parallel port address can not be read

    We just had the parallel port card recommended on this forum shipped over night from Jameco Electronics. After we install it, I/O test says "absent" by LPT1 LPT2 and LPT3. We got the address from device manager (57088) but when we type it into I/O Test, the new version suggested in this forum, it won't send bytes. We please need help ASAP!!! Our lab is shut down and have a major funded data collection that is stalled out because of this issue!

  2. #2
    Join Date
    Nov 2005
    Are you using MediaLab or DirectRT?

  3. #3


    we run both programs using direct rt to send ttl signals to physio coulbourne.

  4. #4
    Join Date
    Nov 2005
    What are you using to test the output of the new parallel port card?

  5. #5
    I/O test. that we downloaded from this forum.

  6. #6
    Join Date
    Oct 2008
    I've been working with Paul on this issue, and here's what I know about the situation so far:

    We installed a Rosewill RC-302 (http://www.rosewill.com/products/474/productDetail.htm) into our machine, and Windows XP SP2 detects it without any problems (see http://www.justinmyers.net/media/ttl/00.png). IOTest, though, doesn't see it at all (http://www.justinmyers.net/media/ttl/03.png). I tried a couple of different LPT port numbers (LPT1 and LPT3, given the device window at http://www.justinmyers.net/media/ttl/01.png), and none of them accept any new values from the IOTest application.

    I also looked for the I/O addresses in Device Manager and found two ranges: DF00-DF07 and DE00-DE07 (http://www.justinmyers.net/media/ttl/02.png). I tried using every address in those ranges (with the new IOTest version from http://support.empirisoft.com/showthread.php?t=717 since I was having the same error as mugur65 described), but none of them worked. (As with the different LPT port options, they didn't accept the new values I was trying to send.)

    As if that weren't all bizarre enough, the computer shipped with Vista Home Premium, and the card liked IOTest well enough after I installed it that time--but after we downgraded to XP (to get DirectRT to work), IOTest doesn't seem to like our port.

    We then followed the advice of another thread on these forums (http://www.empirisoft.com/Support/showthread.php?t=644) and ordered the specific parallel card that thread recommended--and got the exact same result.

    Last edited by jarvis24; 11-11-2008 at 09:10 AM.

  7. #7
    Join Date
    Nov 2005
    If we could get you a copy of DRT for Vista, would that help?

    I was able to parse the links above, by the way.

  8. #8
    Join Date
    Nov 2005
    I may have a solution. John is making me a device that can send and read TTL signals to any given port address and should have it completed by the end of the week. I will then be able to test out some code that I think will solve the problem. I know you are under pressure to find a solution, but can you hold on until Friday or Monday? If so, I should be able to have something for you to try by then.

Similar Threads

  1. Banned email address message when registering
    By jarvis24 in forum Pre-Sales and Licensing FAQ
    Replies: 4
    Last Post: 06-17-2011, 09:12 AM
  2. Can't register my email address?
    By jarvis24 in forum Pre-Sales and Licensing FAQ
    Replies: 2
    Last Post: 06-10-2010, 03:20 PM
  3. Parallel Port and Vista
    By bollsp in forum Hardware Questions
    Replies: 0
    Last Post: 10-30-2008, 01:27 PM
  4. Read me first!
    By jarvis24 in forum DirectRT Older Versions: Sharing Area
    Replies: 0
    Last Post: 04-25-2006, 10:29 AM
  5. Read me first!
    By jarvis24 in forum MediaLab Older Versions: Sharing Area
    Replies: 0
    Last Post: 04-25-2006, 10:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts