Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 3 of 3

Thread: Problems using a button box

  1. #1
    Join Date
    Mar 2006
    Posts
    1

    Problems using a button box

    I am trying to set up my experiment to use a buttonbox, in other words I want DirectRT to recognize the responses on a button box. I have it set up so far that during the I/O test the button box interface can accept the byte sent to it (you can see the value change at the monitor on the bottom), but for some reason it can't read any of the responses from the hardware. I can't figure out if this is an issue with the way I have set it up (ie an issue within DirectRT) or if it is more of a system setup/ buttonbox issue. Any ideas?
    -BTW I am using a button box and interface from another lab so it is not Empirisoft hardware.
    Thanks!

  2. #2
    Join Date
    Nov 2005
    Posts
    294

    Possible Solution

    It sounds like the IOTester utility isn't behaving properly when logged in as a 'superuser.'

    Try this new file and see what happens--it's a newer version of a file that the IOTester uses. Unzip and copy the contained file to your windows system folder (e.g., c:\windows\system32) overwriting the older version of the same file.

    Remember that, in DirectRT, you need to SEND one TTL signal somewhere (anywhere) in order for receiving to work. One outward signal initializes everything that all subsequent inward and outward signals need (e.g., see the TTL sample that comes with DirectRT). Note also that the sample uses port 889 rather than 888 for the parallel port--this is a common port address for incoming data through the parallel port.

    So after you initialize and welcome everyone, send out a character:

    stim=ttl:255, loc=1016, time=10

    and then see if you can then receive incoming data.

    John
    Attached Files Attached Files
    Last edited by jarvis24; 03-18-2006 at 07:15 PM.

  3. #3
    Join Date
    Nov 2005
    Posts
    3,321
    here is version 2.5.9 of ntport.dll. it's the latest version we've been using.
    -blair
    Attached Files Attached Files

Similar Threads

  1. Can you move the password box?
    By jarvis24 in forum MediaLab Older Versions: How Do I...
    Replies: 1
    Last Post: 05-30-2006, 06:52 PM
  2. Button box
    By JEC in forum Hardware: Suggestions & Feedback
    Replies: 0
    Last Post: 05-16-2006, 12:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •