Note though that v2012 is required for this--the fix won't work on earlier versions (not intentional, it's a function of some third party software that needed to be updated in addition to our own...