Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 10 of 10

Thread: Recording stim in data files from stimlist function (case 15001)

  1. #1
    Join Date
    Dec 2012
    Posts
    29

    Recording stim in data files from stimlist function (case 15001)

    Hello,

    I made changes recommended in previous threads, which suggested setting negative block values in order to log random stimuli from a stimlist, but the change doesn't seem to be working for me. Any ideas why this might be the case?

    thanks!

    Nick
    Last edited by jason_reed; 06-25-2014 at 04:26 PM.

  2. #2
    Join Date
    Feb 2013
    Posts
    1,094
    Nick,

    I'm not sure what you mean. Could you please provide the URL to these older forum threads and/or a copy of your input file to help me better understand what you are trying to do?
    Jason Reed
    Empirisoft Software Support Specialist

  3. #3
    Join Date
    Dec 2012
    Posts
    29
    Hi Jason,

    I can't seem to find the exact thread/URL. It was along the lines that in order to record the stimuli that are called on in a stimlist function, you need to set the block to a negative value (-1). I've attached the file. Thanks again -

    NickGambling Task.csv

  4. #4
    Join Date
    Dec 2012
    Posts
    29
    Hi again Jason,

    I've (finally) come across the thread that was dealing with these issues. I hope this clarifies things.

    http://www.empirisoft.com/support/sh...=stimlist+data

    Thanks for your help,

    Nick

  5. #5
    Join Date
    Feb 2013
    Posts
    1,094
    Nick,


    Have you used a nonnegative number in the block column (i.e, 1) and not gotten the specific stimuli shown from the stimlists-I'm assuming in trials numbered 1000 and greater-to appear in the log files?


    On a different matter, I'm curious as to why you did not specify a specific value anytime you used a ttl: option.
    Jason Reed
    Empirisoft Software Support Specialist

  6. #6
    Join Date
    Dec 2012
    Posts
    29
    I tried positive values as well, but the same thing happens - the stim from stimlists (jumps to trials 1000-1063) aren't appearing in the data/log files. Not sure ...

    The csv file I uploaded is a scratch one that I use while editing. I'll put in the ttl values once all of these things are sorted out (to make sure it syncs with our acquisition computer and what not). For the fun of it, I inputted the values anyways to see if this resolved the stim logging issue, but it's still unchanged.

  7. #7
    Join Date
    Dec 2012
    Posts
    29
    Hi Jason,

    Just checking in to see if there's been any progress on this problem? I'm hoping to get the study up and running by the end of the week, so I'm eager to find a solution.

    Thanks!

    Nick

  8. #8
    Join Date
    Feb 2013
    Posts
    1,094
    In trials 1000-1063 of your file, try replacing the display times of 500ms in column X with rt:any. You will also need to add a line to your styles.drt file that has 0-500! in the MinMax field and use that style code in these same trials.


    Basically, any trials that you jump to in an input file will not record any stimuli presented in the output file, even if you use a negative number in the block cells for those trials. To work around this, you need to use the rt: feature in those trials to get DirectRT to record what is going on. The use of 0-500! in the MinMax field will cause DirectRT to automatically proceed, just like you programmed in your original trial.
    Jason Reed
    Empirisoft Software Support Specialist

  9. #9
    Join Date
    Dec 2012
    Posts
    29
    That did the trick, fantastic - thanks!

  10. #10
    Join Date
    Feb 2013
    Posts
    1,094
    Great! Good luck!
    Jason Reed
    Empirisoft Software Support Specialist

Similar Threads

  1. Stimlist for sound files (case 12705)
    By BH84 in forum DirectRT v2018: How Do I...
    Replies: 5
    Last Post: 02-07-2014, 01:35 PM
  2. Data files storing as voice - no voice recording (case 2954)
    By jkl in forum MediaLab v2018: Troubleshooting
    Replies: 3
    Last Post: 03-21-2013, 11:51 PM
  3. not recording audio RT with fixed sound stim
    By KEP9 in forum DirectRT Older Versions: Troubleshooting
    Replies: 1
    Last Post: 05-12-2011, 09:38 AM
  4. Using mouse cursor function with animations (.gif) files
    By rbvance in forum DirectRT Older Versions: How Do I...
    Replies: 2
    Last Post: 02-20-2010, 04:35 AM
  5. recording RT with delayed stim presentation
    By mickeyi in forum DirectRT Older Versions: How Do I...
    Replies: 1
    Last Post: 01-14-2009, 08:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •