Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 10 of 10

Thread: Fail to send a TTL signal due to port number

  1. #1
    Join Date
    Nov 2005
    Posts
    38

    Fail to send a TTL signal due to port number

    I'm using DirectRT 2010.2.103.115, and cannot send TTL to my Mindware system because a problem with the port number.
    Operation system: Windows 7, 64 bit.
    My parallel port number is 57,360 and it seems that the DirectRT can send TTLs only to around 32,000. When I'm trying to send a TTL to 57,360, its giving me a minus sign (-8176), like in the attached document.
    What can I do?

    Roy
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2005
    Posts
    294
    Grab a copy of v2012 from our website... I believe this issue has been resolved.

  3. #3
    Join Date
    Nov 2005
    Posts
    38
    We don't have license for V2012 but only for V2010.
    Wasn't this issue been resolved at V2010?
    Last edited by jarvis24; 06-20-2012 at 08:16 AM.

  4. #4
    Join Date
    Nov 2005
    Posts
    38
    We've installed both version 2010.2.103.115 and version 2010.3.0.109, but wecouldn't send a TTL signal in any of them. I guess it's because our port numberis higher than 32,000, and as I saw at this forum, that it is a known issue.

    We do not have license for DirectRT 2012, but only for 2010, but from theforum it look like this problem has been solved at the 2008 version. So whycan't we send a TTL to port number 57360 on the 2010 versions? Is there somethingwe can do?
    Last edited by jarvis24; 06-20-2012 at 08:16 AM.

  5. #5
    Join Date
    Nov 2005
    Posts
    294
    Send me an email (service @ empirisoft.com) and I'll send you back a utility for testing TTL ports above 32k.
    Last edited by jarvis24; 06-20-2012 at 08:29 AM.

  6. #6
    Join Date
    Nov 2005
    Posts
    3,314
    Note though that v2012 is required for this--the fix won't work on earlier versions (not intentional, it's a function of some third party software that needed to be updated in addition to our own code). In any case, the new IOTest.exe utility (v2012.4.135) should be able to work with IO ports with address values up to 65535 (DEC, i.e., HEX FFFF). If you contact John (via service @ empirisoft.com, you can get the new IOTest.exe utility now (as of June 20, 2012) to see if it works on your system. But do note that DirectRT v2012 will need to be installed. This new version of the IOTest.exe file simply replaces the existing version in the DirectRT\utilities\TTL folder.

    Later this week, the new address functionality will be added to the default setup files of DirectRT and MediaLab posted on the main download page. We're doing it this way to ensure it works first via the test utility before we make the same changes in the code of the main programs (i.e., MediaLab and DirectRT).

    Hope that helps,
    Blair

  7. #7
    Join Date
    Nov 2005
    Posts
    294

    IOTest

    For those who can't receive .zip files in their email, here's a copy.
    Attached Files Attached Files

  8. #8
    Join Date
    Aug 2013
    Posts
    2
    Was this ever resolved? I am trying to send a TTL signal from port 53264 using Media Lab 2012 and it doesn't seem to respond. When I use the I/O utility it works just great.
    Last edited by NuttingBH; 02-24-2014 at 04:27 PM.

  9. #9
    Join Date
    Aug 2013
    Posts
    2
    Doesn't work with 2014 either.

  10. #10
    Join Date
    Nov 2005
    Posts
    294
    Quote Originally Posted by NuttingBH View Post
    Doesn't work with 2014 either.
    FYI this has been fixed in v2014 MediaLab. Contact us for a link to the newest build.

    John

Similar Threads

  1. Having Problem with TTL, Parallel Port, I/O test
    By habrookshirej in forum MediaLab Older Versions: General Questions
    Replies: 2
    Last Post: 12-13-2010, 02:48 PM
  2. How to send a pulse to BIOPAC for a scale response
    By gargibhaduri in forum MediaLab Older Versions: How Do I...
    Replies: 0
    Last Post: 07-07-2010, 05:45 PM
  3. Cable to send DirectRT TTL signal to a BNC input
    By deconroy in forum Hardware: How Do I...
    Replies: 2
    Last Post: 11-10-2008, 09:39 AM
  4. Parallel Port and Vista
    By bollsp in forum Hardware Questions
    Replies: 0
    Last Post: 10-30-2008, 01:27 PM
  5. Port number for a Cedrus device?
    By jarvis24 in forum Hardware: How Do I...
    Replies: 13
    Last Post: 07-11-2006, 04:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •