Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 12 of 12

Thread: Resp and Name columns don't match

  1. #1
    Join Date
    Nov 2005
    Posts
    3,309

    Resp and Name columns don't match

    [edited from support email]

    In going to get keyboard responses out of the log file, I'm noticing the Resp and Name values do not match -- Resp is one number higher than Name (e.g., 6 vs 5, 2 vs 1). Given that they're numeric responses, I assume they should be the same. Is "Name" the subject's actual response?

  2. #2
    Join Date
    Nov 2005
    Posts
    3,309
    Yes, this was a bug we recently fixed. Check out the notes on release 2006.2.15 here:

    www.empirisoft.com/Support/showthread.php?t=273

    -Blair

  3. #3
    Join Date
    Sep 2008
    Posts
    3

    Resp and Name columns still not matching

    Hi guys,

    I've been using the XP version from the end of last year, and found this identical problem: inconsistently, numerical values in the Resp column on the last stimulus of each trial will be one less than the Name column. Two questions: which is the actual response I should be extracting, and should I be concerned that this is inconsistently occurring? It only seems to happen for around a third of the time.

  4. #4
    Join Date
    Sep 2008
    Posts
    3

    Opposite problem

    Just re-read the other problems and realised mine is the opposite way around - could this be due to the counter-measure employed in fixing the original bug? Mine has Resp one LOWER than Name.

  5. #5
    Join Date
    Nov 2005
    Posts
    3,309
    Hmm. What version are you running--i.e., 200x.x.x? If it's any release of v2008, would you please post a sample input file and it's data so I can see what you are getting?

  6. #6
    Join Date
    Sep 2008
    Posts
    3

    Details

    It's version 2008.1.0.11, with the input file 'sampleinput' attached and 'sample2_log' output. On some files, it seems to happen every time, but not on this one. With cell refs I&J 14, 18, 22, 26 etc (wherever the last trial falls), Name=Resp+1. But if you look at I30, it is the same as J30. The same happens on row 254. Perhaps it only happens when Name=1 that Resp is also 1. It is only ever with the last stimulus of each trial though, as the responses to the second stimulus of each trial (stimuli 2 and 4 are identical) are accurately recorded through my DirectRT button box in both Name and Resp columns.

    I'm thinking that 'Name' is the correct column?

    Cheers for your help guys.
    Attached Files Attached Files
    Last edited by jarvis24; 03-31-2009 at 11:19 PM.

  7. #7
    Join Date
    Nov 2005
    Posts
    3,309
    This is odd indeed. Safe to assume you are using v2008? It does seem that in your case response is always one less--unless name = 1. Does this replicate with your keyboard (i.e., if you do not use the button box)? Also, are you using any grid functions (mouse cursor, light gun, touch screen)?

    Could you run the attached, simplified, input file and see if the results are consistent when using your keyboard? If so, could you please attach the log file?
    Attached Files Attached Files
    Last edited by jarvis24; 03-31-2009 at 11:20 PM.

  8. #8
    Join Date
    Aug 2007
    Posts
    12

    Problem with recording "resp" using mouse cursor functionality

    We are trying to record multiple responses on a single trial where participants first make five keypress responses and then five where they click on text-cursor defined areas of the screen. For the mouse click text-cursor responses, the "Name" of each response is being recorded correctly, but sometimes the "Resp" column is incorrect. This error has only been noted on the last reponse, but does not always occur on this last response. Attached are some examples of the log files. In 18_log, response name 5 is incorrectly recorded in the "Resp" column as 4 when this response was the last to be given, but in 22_log, response 5 is correctly recorded in the "Resp" column when it was the first to be given. In 17_log, all responses were correctly recorded in the "Resp" column, including the last one. Any solution? Thanks!
    Attached Files Attached Files

  9. #9
    Join Date
    Nov 2005
    Posts
    3,309
    Does the same pattern emerge if you use the corresponding keystrokes instead of mouse clicks? If so, can you attach or send me a copy of your input file so I can try running it here?

    Also--are the versions of DirectRT the same on all the machines (e.g., especially the one that produced the error free log file?)
    Last edited by jarvis24; 03-31-2009 at 11:22 PM.

  10. #10
    Join Date
    Aug 2007
    Posts
    12
    Yes, the same problem occurs with keypad input. Attached is the zipped file.
    Attached Files Attached Files

  11. #11
    Join Date
    Mar 2007
    Posts
    23

    Same problem

    We are having the exact same problem. Has this issue been resolved? Without a solution, it makes the data unusable.

  12. #12
    Join Date
    Nov 2005
    Posts
    3,309
    Try running the simplified "sampleinput2.csv" input file above. If it works fine but yours does not, then can you tell me if you are using a grid based system (e.g., cursor, touch screen, light gun) at all in your session and what version you are running, i.e., 200x.x.x?
    Last edited by jarvis24; 06-25-2009 at 01:26 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •