Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 5 of 5

Thread: Cannot find file needed to save data

  1. #1

    Cannot find file needed to save data

    I have encountered this problem 3 times, spread across days and computers:

    MediaLab cannot find/gain access to the file needed to save the data for a particular subject. My options are 'OK' which ends the data gathering session, and 'Cancel'. Not wanting to lose data, I clicked OK, which drops the data. Is there a way to prevent this problem?

  2. #2
    Join Date
    Mar 2009
    Posts
    401
    Hi Theo - Let's begin troubleshooting.

    First, what subject IDs are you using for these sessions?

    Is your data being saved to the default data location, or does your preference file specify an alternate location? To check if you're using an alternate data folder, open up MediaLab, select the 'Preferences' menu item, and navigate to 'Edit Preferences'. From here a window will open. Is the 'Use Alternate Data Folder' textbox filled in?

    What version of the software are you currently running? To check, simply go to 'Help' and then 'About MediaLab' .

  3. #3
    Join Date
    Nov 2009
    Posts
    1
    Hello. I'm Corey, the student researcher who originally asked this question.

    I've completed data gathering with Medialab for this semester. Its an impressive program.

    After reviewing the output files, it would seem my earlier statement, (that I lost data), was too hasty.

    At the end of the experiment, the blue background of the experiment launcher would appear, and a dialogue box would appear saying the data couldn't be written because the folder couldn't be found (not verbatim). I would click ok. In one case a participant completed the experiment again.

    For the two participants who could not complete the experiment again, there was a blank row in the excel datafile on the network drive (our computer lab is connected to the university network, and my experiment files were hosted on a network drive tied to a particular login.) After the first error, when I'd open the excel file after gathering new data, Excel would give an error message about storing more than 206? columns of data.

    At the end of the last data-gathering session, I closely reviewed the excel file, and found the beginning of the row of data for the missing participants appended to the end of the previous participant's data, truncated because of the column limit. Reviewing the .txt file, I found the entire record.

    I did not lose data as I earlier believed.

    I suspect that the error was related to the way I ran the lab. New participants arrived on the top of the hour. Most would finish before the end of the first 20 minutes. I would immediately load the experiment file again, leaving the prompt for subject number and condition number on the screen for up to 40 minutes before the next participant used the terminal. I suspect there was a timeout in either the program or the network, as occasionally the delay between participants (with Medialab sitting with the experiment open) would be longer than an hour with no activity on the computer, and that this timeout resulted in the errors in saving data to the excel file.

    At this time I am not seeking support from Empirisoft to resolve any problem. If this is not an expected behavior, please consider this constructive feedback. If you are aware of how to protect against this in the future (as I intend to continue to use Medialab in future semesters,) I would appreciate a reply here or an email (cooperco@mail.gvsu.edu).

    Thank you for your time!

    Corey Cooper

  4. #4
    Join Date
    Nov 2005
    Posts
    3,320
    Thanks for the feedback Theo. By chance could you have left any of the sessions ready to go but then canceled them, e.g., because it was the end of the day and there was a no-show? I have heard of this kind of scenario causing the next session's data to append to the last line of real data. In such cases, as you found, a manual hard return in the text files was required to move the data to the next line. In any case, we'll certainly add this to our fix list for the next version.

  5. #5
    Join Date
    Feb 2008
    Posts
    19

    Unable to create or access data folders

    I've just upgraded my ML on several computers and am having a problems on one computer, and I think it's the same problem you're discussing here.

    When we launch an experiment or a questionnaire, we get the following:

    Unable to create or access data folders. If running an experiment off of a CD-ROM, specify an alternate data folder in preferences

    We've tried creating new preference files for each experiment, designating the experiment folder as the place to write the data. This solution worked for one experiment, but it happened again and this solution isn't working.

Similar Threads

  1. Input file key codes vs. data file Resp?
    By David McFarlane in forum DirectRT Older Versions: How Do I...
    Replies: 6
    Last Post: 09-16-2009, 01:16 PM
  2. Experiment can't find bitmap
    By sscielzo in forum MediaLab Older Versions: Troubleshooting
    Replies: 1
    Last Post: 01-23-2008, 03:34 PM
  3. Can DirectRT Perform Needed Randomization?
    By balford@work in forum DirectRT Older Versions: How Do I...
    Replies: 2
    Last Post: 10-01-2007, 09:38 AM
  4. How do I recreate the input file from a resulting data file?
    By teddenney in forum DirectRT Older Versions: How Do I...
    Replies: 1
    Last Post: 03-19-2007, 07:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •