Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 4 of 4

Thread: Sending TTLs: When MediaLab 2018 works, but DirectRT 2018 doesn't case 34924)

  1. #1
    Join Date
    Feb 2014
    Posts
    14

    Sending TTLs: When MediaLab 2018 works, but DirectRT 2018 doesn't case 34924)

    Hello, I have an interesting case that sending TTLs from DirectRT 2018 does not work, while MediaLab 2018 do.

    I have a PCI printer card inserted to the PC, and the IO Test shows that the port number is -9216 (or, DC00H).

    Latest version of MediaLab 2018 handles it nice and easy. No problem with sending TTLs from ML2018.

    However, DirectRT 2018 could not send TTLs. I wonder if this is due to using a negative number for output (since Help file reads that it will accept numbers ranging from 0 to 65535).

    Any thoughts to work around this issue?

    I am attaching the files used for my DirectRT experiment.

    Thanks,

    "Raymond" Byungho Park



    P.S. The issue mentioned here is similar to the one discussed in the thread below. However, it seems that DirectRT 2014 could solve the TTL issue when it was raised at the time. I guess there is something different this time.

    [ Fail to send a TTL signal due to port number ]
    http://www.empirisoft.com/support/sh...to-port-number
    Attached Files Attached Files
    Last edited by jason_reed; 07-09-2019 at 08:11 AM.

  2. #2
    Join Date
    Feb 2013
    Posts
    1,082
    Can you try your files on a computer where the printer card is not a peripheral but directly connected to the motherboard?
    Jason Reed
    Empirisoft Software Support Specialist

  3. #3
    Join Date
    Feb 2014
    Posts
    14

    Afraid not -- do not have the old machine.

    The old machine with on board parallel port has been phased out. So no, unfortunately.
    Do you have any other suggestions? Do you think there is a way to "trick" DirectRT by plugging in some other number as output port #?

  4. #4
    Join Date
    Feb 2014
    Posts
    14

    Am I out of luck?

    Quote Originally Posted by jason_reed View Post
    Can you try your files on a computer where the printer card is not a peripheral but directly connected to the motherboard?
    It has been several days since I've been asked whether I have access to a "traditional computer" with a parallel port embedded in a mother board. I do not have access to old technology at this point: So the question here is -- am I out of luck?

    I tried plugging other numbers that *might* work but none of them did. I am still puzzled that the same port number that works for Media Lab does not work for Direct RT. Is this technical issue the first of its kind that has been ever reported to Empirisoft?

    "Raymond" Byungho Park

Similar Threads

  1. DirectRT Version 2018
    By jarvis24 in forum DirectRT v2018: Version History
    Replies: 1
    Last Post: 04-18-2019, 08:08 PM
  2. MediaLab Version 2018
    By jarvis24 in forum MediaLab v2018: Version History
    Replies: 1
    Last Post: 04-18-2019, 08:03 PM
  3. TTL Not Working In DirectRT, Works Fine in MediaLab and I/O Test (case 33630)
    By krwise in forum DirectRT Older Versions: Troubleshooting
    Replies: 1
    Last Post: 02-20-2019, 08:05 AM
  4. Replies: 1
    Last Post: 10-31-2014, 02:31 PM
  5. MediaLab doesn't return after running DirectRT
    By rabinowitzj in forum MediaLab Older Versions: Troubleshooting
    Replies: 10
    Last Post: 04-23-2008, 03:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •