Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 7 of 7

Thread: Style error - for every .csv file I save? (case 29572)

  1. #1
    Join Date
    Nov 2017
    Posts
    4

    Style error - for every .csv file I save? (case 29572)

    Hello,

    I am trying to code an experiment (DirectRT version 2016.1.104) but whenever I try to run it, I get the following message: "Row 2 requests style code 0, which does not exist in the style file (.drt) for this session". As it seems from reading other threads in this forum, this is a problem many people have faced before and is not necessarily related to the styles file itself. In my particular case, it seems that it pops up for any .csv file I save myself - that means basically that I can run all the original sample files, but whenever I make any changes to them (even the ones instructed by the DirectRT tutorial) it does not run anymore. I'm guessing this could be due to a compatibility issue between Excel and DirectRT versions (for instance, is the whole code really supposed to be crammed into the first column, or should each command be written into individual cells?), but I could be wrong. Anyway, I would much appreciate any input on this!

    Thanks a lot in advance.
    Last edited by jason_reed; 11-29-2017 at 09:18 AM.

  2. #2
    Join Date
    Nov 2017
    Posts
    4
    I think I might have found a hint to what's wrong in another thread - I am using a german version of Excel, so the regional settings are causing the .csv file to be formatted in a wrong way and thus unusable as an input file. I will try to reset the regional settings to USA and see what happens next.

  3. #3
    Join Date
    Feb 2013
    Posts
    1,018
    Please do try using the English based version of Excel (and an English based version of the Windows operating system if possible) and let me know what happens.
    Jason Reed
    Empirisoft Software Support Specialist

  4. #4
    Join Date
    Nov 2017
    Posts
    4
    Dear Jason,

    Thank you for your quick reply.
    I managed to run the experiment last week by changing my regional settings and rewriting the code using Calc (Open Office), but as soon as I made some new changes to the input file, I got the same problem again.

    I solved it by copying and pasting the whole content into a new spreadsheet, but now I have a different problem: my images are not being shown. That means the experiment runs just fine for the instructions and practice trials (text based), but I get a frozen blank screen when my images are supposed to appear.

    This is the error code dispalyed in the TrackPerformance file:

    Subject 1, 12/5/2017, 14:01:22.02 pm, v2016.1.104, Initial Display: 1600x900, 32-bit colour, 60hz or 16.67ms/screenSubject 1, 12/5/2017, 2:01:25 PM, v2016.1.104, Session Display: 1600x900, 16-bit colour, 60hz or 16.67ms/screen
    Elapsed Time: 100951ms, block 1, trial 85, stim 1, Error 9, Subscript out of range, on line 200, during FlipScreen of Form DDFullScreen

    I noticed there is an incompatibility between the times formats (24H x 12H) from the first to the second line of the Track Performance file. When I ran the experiment successfully before, there was no such incompatibility. Could this be the cause of the crash? The image files have not been changed and they were being displayed correctly last week.


    Any help would be greatly appreciated!



    Roberta

  5. #5
    Join Date
    Feb 2013
    Posts
    1,018
    First, check to make sure that your image files are in the .bmp format and are 8-bit color depth. DirectRT tends to work best with images of an 8-bit depth. It's not too difficult to do this conversion. Here are the steps, which you can also find in here in the online DirectRT manual (http://www.empirisoft.com/directrt/h...mage_files.htm):
    1) Donwload the free program IrfanView at http://www.irfanview.com/.
    2) Open Irfanview and open the image that you want to change.
    3) From the Image Menu, select Decrease Color Depth.
    4) Select 256 colours and save your image.

    If the problem still persists, I'd like to try to run the files on my copy of DirectRT. Please get a copy of the all files I would need to run it in DirectRT and either upload them here or send them directly to support@empirisoft.com (and mention case 29572).
    Jason Reed
    Empirisoft Software Support Specialist

  6. #6
    Join Date
    Nov 2017
    Posts
    4
    Dear Jason,


    Thank you for your reply.
    I already solved the problem, it had nothing to do with the images (I followed all the instructions in the manual for saving them). The crashed was caused by the fact that I added quotation marks to my time commands (as in "rt:aud,rec,-1000"). Now I removed them and everything is running smoothly again.


    Best wishes,



    Roberta

  7. #7
    Join Date
    Feb 2013
    Posts
    1,018
    Roberta,

    I'm glad that the issue is resolved.

    Please let us know if you need further assistance.
    Jason Reed
    Empirisoft Software Support Specialist

Similar Threads

  1. Input file style error message (case 18341)
    By nludwig in forum DirectRT v2016: Troubleshooting
    Replies: 3
    Last Post: 03-23-2015, 10:57 AM
  2. Style error on long file (case 11457)
    By dalabuser13 in forum DirectRT v2016: Troubleshooting
    Replies: 13
    Last Post: 12-02-2013, 04:34 PM
  3. Replies: 4
    Last Post: 03-14-2013, 11:05 AM
  4. Row 17 requests style code 16, which does not exist in the style file
    By jarvis24 in forum DirectRT Older Versions: Troubleshooting
    Replies: 18
    Last Post: 05-02-2012, 12:56 AM
  5. Cannot find file needed to save data
    By Theo in forum MediaLab Older Versions: Troubleshooting
    Replies: 4
    Last Post: 01-13-2010, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •