Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 7 of 7

Thread: DirectRT stops running stimuli during test

  1. #1
    Join Date
    Oct 2008
    Posts
    4

    DirectRT stops running stimuli during test

    I am encountering a problem where DirectRT stops running stimuli as if the input file is done very early in the test. We believe it has to do with when a subject responds to stimuli, it may be when there is a false answer. We have two 'jump to' functions.

    This seems to only happen on a certain file, but the file appears to be written the same as our other input files.

  2. #2
    Join Date
    Nov 2005
    Posts
    3,309
    Can you post your input file? Would be happy to take a look. Normally a session would end a trial ID for a jump is not found. If it is there, it would be odd for it to be skipped over.

  3. #3
    Join Date
    Oct 2008
    Posts
    4
    I have attached two files. The first is the one (ROantb+) that ends DirectRT early. The longest we have gotten it to run is to the 114th trial (fleac)

    The second is one (ROant1a+) that we have gotten to run all the way through and have only made the change of numbering the trials 1-160 since and seemed to run OK.

    Thank you.
    Attached Files Attached Files

  4. #4
    Join Date
    Nov 2005
    Posts
    3,309
    Nothing obviously wrong as far as I can see. If you run through a trial session with ROantb+ and give the same response on each trial (e.g., always 203, always 205, or always 208), will it always quit at the same spot?

  5. #5
    Join Date
    Nov 2005
    Posts
    3,309
    [edited from support email]

    I actually think I found the problem and would just like confirmation. Our variable in position 158 is generally where the survey abruptly cuts off. However I just noticed that the skip is incorrectly programmed to skip to a preceding variable for all but two of the possible response categories. Would this cause the experiment to end? It is currently programmed to skip to 'everdrunk' which occurred at position 118 instead of rmeligion at position 161.
    Yes, a backwards jump or skip would cause it to end because DirectRT simply skips trials until it finds the one it's looking for. If it is never found (in the forward direction), the session would end.

  6. #6
    Join Date
    Oct 2008
    Posts
    4
    We haven't gone through a file using only one response, yet. We do, however, believe that the crash has to do with too fast of a response time. It seems to be crashing on swifter responses, which seem to be within 200 miliseconds or less from the word stimuli. Has this been a problem in the past for anyone?

  7. #7
    Join Date
    Oct 2008
    Posts
    4
    The software doesn't seem to consistently crash dependent on which button (203, 205, 208) is pressed, but it does seem more consistent that it crashes when response time is quicker (about 200 miliseconds or less).

Similar Threads

  1. Another instance of DirectRT already running
    By jarvis24 in forum MediaLab Older Versions: Troubleshooting
    Replies: 3
    Last Post: 03-01-2010, 06:03 AM
  2. MediaLab doesn't return after running DirectRT
    By rabinowitzj in forum MediaLab Older Versions: Troubleshooting
    Replies: 10
    Last Post: 04-23-2008, 04:23 PM
  3. application stops followed by blank screen in Direct RT
    By Kell in forum DirectRT Older Versions: Troubleshooting
    Replies: 3
    Last Post: 09-25-2007, 08:54 AM
  4. Using Responses from MediaLab as Stimuli in DirectRT
    By SRV in forum DirectRT Older Versions: How Do I...
    Replies: 1
    Last Post: 06-13-2006, 03:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •