Empirisoft Support

    Welcome to Empirisoft Support
Results 1 to 10 of 10

Thread: Trouble with input files when using German regional settings

  1. #1
    Join Date
    Nov 2005
    Posts
    3,320

    Trouble with input files when using German regional settings

    When saving .csv files on computers with certain regional settings (e.g., German, Dutch) the files can no longer be used as input files in DirectRT. This is a solution summary contributred by one of our users in Germany. -Blair

    [edited from support email]

    We have discovered we have to have German regional settings to use the MediaLab Experiment Editor (otherwise the file type mismatch error message appears) but then we are unable to alter DirectRT csv files.

    The DirectRT csv files are ONLY editable with USA settings. Even if we alter only one word of the full functioning sample file and save the change using the german settings, it won't work anymore. Our original file (which looks fine, but won't work, as you might recall) is somehow victim of those usa/germany switches.

    If we open csv files (e.g. the sample files) using the American settings, they are presented in cells and columns and stuff (just the way you are used to it, while working with excel). If we on the other hand open them using German settings it's one line, separated with commas, which is hard and time consuming to edit (and which won't work). So making a long story short:
    1. We need US settings to alter csv files (which makes it impossible to use the editor)
    2. We need the German settings to use the MediaLab editor (which makes it impossible to alter DirectRT input files)
    3. Somehow the switching of regional settings is can sometimes lead to errors when translating the original file
    4. The impact of switching regional settings seems like it may be related to the regional settings you use while installing MediaLab and DirectRT (and is independent of the ML or DRT version we use)
    Please let me know what you think about this and if there is an easy way to avoid these problems (perhaps in installing the programs with the American regional settings?).
    Last edited by jarvis24; 10-07-2009 at 03:46 PM.

  2. #2
    Join Date
    Nov 2005
    Posts
    3,320
    It's true that working with MediaLab is much easier if you work in your native regional setting--this helps very much in trying to get your native fonts to appear correctly.

    It's also true that DirectRT .csv files can not be saved properly when using some regional settings (e.g., German, Dutch). When this happens, it is usually because the computer does not use commas as the data field separator in .csv files (even though csv stands for comma separated values).

    One easy fix for this is to set the regional settings to USA while editing .csv files. This will keep them structured properly. You can change back after editing and saving the files.

    Another solution would be to keep your regional settings but change the default list separator to a comma. There is a little known setting in Windows can do this for you. You can set any character to use as your delimiter when saving an Excel file as csv. The key is in Windows Regional Settings:
    1. Bring up your default options window by clicking Start -> Settings -> Control Panel -> Regional Settings.
    2. Beside where you have indicated your regional setting, click Customize.
    3. Click the Number tab and in the List Separator field, replace the current default separator with a comma.
    4. Click OK to save the change and close the window.
    You should now be able to save Excel files as comma delimited files without changing the rest of your regional settings.

    -Blair
    Last edited by jarvis24; 10-23-2006 at 04:56 PM.

  3. #3
    Join Date
    Nov 2005
    Posts
    3,320
    [edited from support email]

    Thanks for the help. I've tried to modify the setting as you suggested. At least in the Dutch setting, we need to do one extra change that is to change the "decimal symbol" from comma to dot (.). Probably this is by default, but perhaps it's better to indicate in the post as well, just for people who are not familiar with those settings. Now it works on my computer!

  4. #4
    Join Date
    Feb 2007
    Posts
    12
    Especially for German users:
    Beside the way described above, there is another way to save the .csv files with a comma as the list seperator and every cell in quotes that includes a comma.
    You can download a wonderful Add-In from Nils Kaczenski's Homepage: http://www.kaczenski.de/2004/09/27/excel-csv-addin/
    German installation description can be found here (at the bottom of the page): http://www.faq-o-matic.net/content/view/85/80/

    Or just copy it to your Application Data\Microsoft\AddIns folder in your home directory.
    Start the Add-In with Shift+Ctrl+X. Then select the place where to save the file and the seperator (,).
    Works fine.

  5. #5
    Join Date
    Sep 2007
    Posts
    4

    Trouble with input files when using German regional settings

    Just changing German regional settings into American settings did not work.
    But removing DirectRT, changing German settings into American and reinstalling DirectRT works fine! :-)
    Please inform other German users about it because it took me some sleepless nights to find out! Do not wish that to others!
    Andrea

  6. #6

    still problems...

    Ok, so Ive changed the german regional setting to the american one, I replaced the default seperator with a comma and I deinstalled and reinstalled Direct RT...it still does not work, what can I do? Could Excel 07 be the problem?

  7. #7
    Join Date
    Nov 2005
    Posts
    3,320
    Can you post a copy of the input file you are trying to run?

  8. #8
    Ive solved the problem by using open office! This works perfectly.

  9. #9
    Join Date
    Nov 2005
    Posts
    3,320
    Hmmm, I wonder why. In any case, thanks for the update, good to hear you found yourself a solution!

  10. #10

    No need to change regional setting w Open office

    Located in Sweden I suffered from the same problem. Found very simple solution:

    Install Open office (Oo) (my version is 3.3), it is free.

    When you open a csv in Oo, the program will automatically ask you about the formatting instead of automatically changing it as in excel - choose separated by commas as in attached picture.

    No regional settings change needed!!!

    Jarvis - why not recommend Open office as default. It's free and obviously works better with DirectRT. Info on this matter and on the settings issue would have saved me a lot of pain for sure.


Similar Threads

  1. Trouble with image colors
    By jarvis24 in forum DirectRT Older Versions: Troubleshooting
    Replies: 10
    Last Post: 04-19-2010, 04:18 PM
  2. Trouble with incorrect responses
    By jarvis24 in forum DirectRT Older Versions: Troubleshooting
    Replies: 1
    Last Post: 10-02-2006, 07:33 PM
  3. DirectRT generating extra copies of my input file?
    By jarvis24 in forum DirectRT Older Versions: Troubleshooting
    Replies: 1
    Last Post: 09-19-2006, 12:48 PM
  4. Style file settings not being applied
    By jarvis24 in forum DirectRT Older Versions: Troubleshooting
    Replies: 1
    Last Post: 02-21-2006, 06:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •